Skip to main content

このバージョンの GitHub Enterprise サーバーはこの日付をもって終了となります: 2024-03-07. 重大なセキュリティの問題に対してであっても、パッチリリースは作成されません。 パフォーマンスの向上、セキュリティの向上、新機能の向上を図るために、最新バージョンの GitHub Enterprise サーバーにアップグレードしてください。 アップグレードに関するヘルプについては、GitHub Enterprise サポートにお問い合わせください

エラー: ".ql ファイル、.qls ファイル、ディレクトリ、またはクエリ パック仕様ではありません"

CodeQL で、分析用に指定されたクエリまたはクエリ セットの 1 つを見つけることができませんでした。

このエラーについて

Is not a .ql file, .qls file, a directory, or a query pack specification.

このエラーは、CodeQL によって、ワークフローで要求されている場所で名前付きクエリ、クエリ スイート、またはクエリ パックを見つけることができない場合に表示されます。

エラーの原因を確認する

一般に、このエラーには 2 つの理由があります。

  • ワークフローに入力ミスがあります。
  • ワークフローでパスにより参照されているリソースが、名前を変更、削除、または新しい場所に移動されました。

問題を修正する

リソースの場所を確認した後、正しい場所を指定するようにワークフローを更新できます。