Skip to main content

Diese Version von GitHub Enterprise Server wird eingestellt am 2024-06-29. Es wird keine Patch-Freigabe vorgenommen, auch nicht für kritische Sicherheitsprobleme. Für bessere Leistung, verbesserte Sicherheit und neue Features aktualisiere auf die neueste Version von GitHub Enterprise Server. Wende dich an den GitHub Enterprise-Support, um Hilfe zum Upgrade zu erhalten.

Fehler: ssh-add: unrechtmäßige Option – apple-use-keychain

Diese Fehlermeldung bedeutet, dass deine Version von ssh-add die macOS-Keychainintegration nicht unterstützt, die das Speichern deiner Passphrase in der Keychain ermöglicht.

Die Option --apple-use-keychain ist in Apples Standardversion von ssh-add, die die Passphrase in deiner Schlüsselkette für dich speichert, wenn du einen SSH-Schlüssel zum SSH-Agenten hinzufügst. Wenn du eine andere Version von ssh-add installiert hast, fehlt möglicherweise die Unterstützung für --apple-use-keychain.

Das Problem beheben

Um deinen privaten SSH-Schlüssel zum SSH-Agent hinzuzufügen, kannst du den Pfad zur Apple-Version von ssh-add angeben:

/usr/bin/ssh-add --apple-use-keychain ~/.ssh/id_ed25519

Hinweise:

  • Die Option --apple-use-keychain ist in der Standardversion von ssh-add von Apple enthalten. Verwende bei MacOS-Versionen vor Monterey (12.0) -K statt --apple-use-keychain.
  • Wenn Sie Ihren Schlüssel mit einem anderen Namen erstellt haben oder wenn Sie einen vorhandenen Schlüssel mit einem anderen Namen hinzufügen, ersetzen Sie id_ed25519 im Befehl durch den Namen Ihrer privaten Schlüsseldatei.

Weiterführende Themen