Skip to main content

Suporte a linguagem do GitHub

Uma visão geral das linguagens de programação compatível com as funcionalidades de GitHub

Sobre as linguagens compatíveis

A maioria das funcionalidades de GitHub funcionam independentemente de qual linguagem seu código está escrito. Você pode procurar código ou habilitar o destaque de sintaxe com base em qualquer linguagem conhecida como GitHub. Para obter mais informações, consulte "Pesquisar código" ou "Criar e destacar blocos de código".

Alguns produtos de GitHub têm funcionalidades que atualmente só são compatíveis com por um subconjunto de linguagens de programação.

Linguagens principais compatíveis com funcionalidades de GitHub

As linguagens principais para funcionalidades de GitHub incluem C, C++, C#, Go, Java, JavaScript, PHP, Python, Ruby, Scala e TypeScript. Para funcionalidades que gerenciam pacotes de suporte, os gerentes de pacotes atualmente compatíveis são incluídos na tabela com suas linguagens relevantes.

Algumas linguagens são compatíveis para gerentes de linguagens ou pacotes adicionais. Se você quer saber se outra linguagem é compatível para uma funcionalidade solicitar suporte para uma linguagem, acesse o Fórum da Comunidade.

| Linguagem | Varredura de código | Dependency graph, Alertas do Dependabot, Atualizações de segurança do Dependabot || Atualizações de versão do Dependabot| | GitHub Actions | GitHub Package Registry | | :-- | :-: | :-: | :-: | :-: | :-: | | C || | | | | | | C++ || | | | | | | C# || |
dotnet CLI |
dotnet CLI | |
dotnet CLI | | Go || |
Go modules |
Go modules | | | | Java || |
Maven |
Maven, Gradle | |
Maven, Gradle | | JavaScript || |
npm, Yarn |
npm | |
npm | | PHP || 1 |
Composer |
Composer | | | | Python || |
pip |
pip | | | | Ruby || 1 |
RubyGems |
RubyGems | |
RubyGems | | Scala || 1 |
Maven, Gradle |
Maven, Gradle | | | | TypeScript || |
npm, Yarn |
npm | |
npm |

[1] Essas linguagens são compatíveis com Varredura de código por ações de terceiros.