Skip to main content

Diese Version von GitHub Enterprise Server wird eingestellt am 2024-06-29. Es wird keine Patch-Freigabe vorgenommen, auch nicht für kritische Sicherheitsprobleme. Für bessere Leistung, verbesserte Sicherheit und neue Features aktualisiere auf die neueste Version von GitHub Enterprise Server. Wende dich an den GitHub Enterprise-Support, um Hilfe zum Upgrade zu erhalten.

Swift-Abfragen für die CodeQL-Analyse

Erkunden Sie die Abfragen, die CodeQL zum Analysieren von Code verwendet, der in Swift geschrieben wurde, wenn Sie die Abfragesammlung default oder security-extended auswählen.

Wer kann dieses Feature verwenden?

Code scanning ist für organisationseigene Repositorys in GitHub Enterprise Server verfügbar. Dieses Feature erfordert eine Lizenz für GitHub Advanced Security. Weitere Informationen findest du unter Informationen zu GitHub Advanced Security.

CodeQL enthält viele Abfragen zum Analysieren von Swift-Code. Alle Abfragen in der default Abfragesammlung werden standardmäßig ausgeführt. Wenn Sie sich für die Verwendung der security-extended Abfragesammlung entscheiden, werden zusätzliche Abfragen ausgeführt. Weitere Informationen findest du unter CodeQL-Abfragesammlungen.

Integrierte Abfragen für die Swift-Analyse

In dieser Tabelle sind die Abfragen aufgeführt, die mit der neuesten Version der Aktion CodeQL und CodeQL CLI verfügbar sind. Weitere Informationen finden Sie unter CodeQL-Änderungsprotokollen auf der Dokumentationsseite zu CodeQL.

Hinweis: Die erste Version von GitHub Enterprise Server 3.9 enthielt CodeQL-Aktion und CodeQL CLI 2.12.7, die möglicherweise nicht alle diese Abfragen enthalten. Ihr Website-Administrator kann Ihre CodeQL-Version auf eine neuere Version aktualisieren. Weitere Informationen findest du unter Konfigurieren der Codeüberprüfung für Ihre Anwendung.

AbfragenameVerwandte CWEsStandardErweitert
Ungültige HTML-Filterung regexp116, 020, 185, 186
Protokollierung von Klartext vertraulicher Informationen312, 359, 532
Speicherung von Klartext vertraulicher Informationen in einer lokalen Datenbank312
Speicherung von Klartext vertraulicher Informationen in einem Anwendungseinstellungsspeicher312
Übertragung von Klartext vertraulicher Informationen319
Konstantes Passwort259
Datenbankabfrage, die aus benutzerdefinierten Quellen erstellt wurde089
Verschlüsselung mit ECB327
Hardcodierter Schlüssel321
Unvollständiger regulärer Ausdruck für Hostnamen020
Ineffizienter regulärer Ausdruck1333, 730, 400
Unsichere TLS-Konfiguration757
Unzureichende Hash-Iterationen916
Fehlender Anchor des regulären Ausdrucks020
Prädikat, das aus benutzerdefinierten Quellen erstellt wurde943
Einspeisung regulärer Ausdrücke730, 400
Auflösen der externen XML-Entität in benutzergesteuerten Daten611, 776, 827
Statischer Initialisierungsvektor für die Verschlüsselung329, 1204
Zusammenführung von Zeichenkettenlängen135
Aus benutzerdefinierten Quellen erstellter Systembefehl078, 088
Nicht kontrollierte Daten, die im Pfadausdruck verwendet werden022, 023, 036, 073, 099
Unkontrollierte Formatzeichenkette134
Unsicherer WebView-Abruf079, 095, 749
Verwendung eines fehlerhaften oder schwachen kryptografischen Hashalgorithmus für vertrauliche Daten327, 328
Verwendung eines unangemessenen kryptografischen Hashalgorithmus für Passwörter327, 328, 916
Verwendung konstanter Salts760
JavaScript-Einspeisung094, 095, 749