Skip to main content

이 버전의 GitHub Enterprise Server는 다음 날짜에 중단됩니다. 2024-06-29. 중요한 보안 문제에 대해서도 패치 릴리스가 이루어지지 않습니다. 더 뛰어난 성능, 향상된 보안, 새로운 기능을 위해 최신 버전의 GitHub Enterprise Server로 업그레이드합니다. 업그레이드에 대한 도움말은 GitHub Enterprise 지원에 문의하세요.

API 버전

REST API를 요청할 때마다 사용할 REST API 버전을 지정하는 방법을 알아봅니다.

API 버전 관리 정보

GitHub Enterprise Server REST API의 버전이 지정됩니다. API 버전의 이름은 API 버전이 릴리스된 날짜를 기반으로 합니다. 예를 들어 API 버전 2022-11-28은(는) Mon, 28 Nov 2022에 릴리스되었습니다.

호환성이 손상되는 모든 변경 내용이 새 API 버전에서 릴리스됩니다. 호환성이 손상되는 변경은 통합을 손상시킬 수 있는 변경의 내용입니다. 다음은 호환성이 손상되는 변경 사항들입니다.

  • 전체 작업 제거하기
  • 매개 변수 이름 바꾸기 또는 제거하기
  • 응답 필드 제거하기 또는 이름 바꾸기
  • 새 필수 매개 변수 추가하기
  • 이전의 필요한 선택적 매개 변수 만들기
  • 매개 변수 또는 응답 필드의 형식 변경하기
  • 열거형 값 제거하기
  • 기존 매개 변수에 새 유효성 검사 규칙 추가하기
  • 인증 또는 권한 부여 요구 사항 변경하기

모든 추가(호환되지 않는) 변경 내용은 지원되는 모든 API 버전 내에서 사용할 수 있습니다. 추가 변경 내용은 통합을 중단해서는 안 되는 변경 내용입니다. 추가 변경 내용은 다음과 같습니다.

  • 작업 추가하기
  • 선택적 매개 변수 추가하기
  • 선택적 요청 헤더 추가하기
  • 응답 필드 추가하기
  • 응답 헤더 추가하기
  • 열거형 값 추가하기

새 REST API 버전이 릴리스되면 새 API 버전이 릴리스된 후 최소 24개월 동안만 이전 API 버전이 지원됩니다.

GitHub Enterprise Server 버전 관리 및 REST API 버전 관리 정보

GitHub Enterprise Server 버전은 REST API 버전에서 분리됩니다. GitHub Enterprise Server 버전을 업그레이드할 수 있지만 API 버전이 GitHub Enterprise Server 버전에 포함되어 있는 한 동일한 REST API 버전을 유지할 수 있습니다. 마찬가지로 선택한 새 REST API 버전을 GitHub Enterprise Server 버전에 사용할 수 있는 한 GitHub Enterprise Server 버전을 업데이트하지 않고 REST API 버전을 업그레이드할 수 있습니다.

REST API 버전이 더 이상 지원되지 않는 경우 GitHub Enterprise Server 릴리스 정보에 표시됩니다. 자세한 정보는 "릴리스 정보"을(를) 참조하세요.

API 버전 지정

X-GitHub-Api-Version 헤더를 사용하여 API 버전을 지정해야 합니다. 예시:

curl --header "X-GitHub-Api-Version:2022-11-28" https://api.github.com/zen

X-GitHub-Api-Version 헤더가 없는 요청은 기본적으로 2022-11-28 버전을 사용합니다.

더 이상 지원되지 않는 API 버전을 지정하면 400 오류가 발생합니다.

새 API 버전으로 업그레이드

새 REST API 버전으로 업그레이드하기 전에 새 API 버전에 해당하는 호환성이 손상되는 변경을 확인하고 포함된 호환성이 손상되는 변경 내용을 이해하고 해당 특정 API 버전으로 업그레이드하는 방법에 대해 자세히 알아봅니다. 자세한 내용은 "호환성이 손상되는 변경"을(를) 참조하세요.

X-GitHub-Api-Version 헤더에서 새 API 버전을 지정하도록 통합을 업데이트하는 경우 새 API 버전과 함께 작동하려면 통합에 필요한 변경 내용도 변경해야 합니다.

통합이 업데이트되면 통합을 테스트하여 새 API 버전에서 작동하는지 확인합니다.

지원되는 API 버전

현재 지원되는 REST API 버전은 다음과 같습니다.

2022-11-28

API 요청을 만들어 지원되는 모든 API 버전을 가져올 수도 있습니다. 자세한 내용은 "메타 데이터에 대한 REST API 엔드포인트"을(를) 참조하세요.