Skip to main content

Esta versión de GitHub Enterprise Server se discontinuará el 2024-08-29. No se realizarán lanzamientos de patch, ni siquiera para problemas de seguridad críticos. Para obtener rendimiento mejorado, seguridad mejorada y nuevas características, actualice a la versión más reciente de GitHub Enterprise Server. Para obtener ayuda con la actualización, póngase en contacto con el soporte técnico de GitHub Enterprise.

Consultas de Python para el análisis de CodeQL

Explore las consultas que CodeQL usa para analizar el código escrito en Python al seleccionar default o el conjunto de consultas security-extended.

¿Quién puede utilizar esta característica?

Code scanning está disponible para repositorios que son propiedad de una organización en GitHub Enterprise Server. Esta característica requiere una licencia para la GitHub Advanced Security. Para obtener más información, vea «Acerca de GitHub Advanced Security».

CodeQL incluye muchas consultas para analizar código de Python. Todas las consultas del conjunto de consultas default se ejecutan de manera predeterminada. Si decide usar el conjunto de consultas security-extended, se ejecutan consultas adicionales. Para obtener más información, vea «Conjuntos de consultas codeQL».

Consultas integradas para el análisis de Python

En esta tabla se enumeran las consultas disponibles con la versión más reciente de la acción CodeQL y CodeQL CLI. Para obtener más información, consulte "Registros de cambios CodeQL" en el sitio de documentación de CodeQL.

Nota: La versión inicial de GitHub Enterprise Server 3.10 incluía la acción CodeQL y CodeQL CLI 2.13.5, que puede no incluir todas estas consultas. El administrador del sitio puede actualizar la versión de CodeQL a una versión más reciente. Para obtener más información, vea «Configuración la digitalización de código para el dispositivo».

Nombre de la consultaCWE relacionadosValor predeterminadoAmpliadoAutofix
Aceptación de claves de host SSH desconocidas al usar Paramiko295
Expresión regular de filtrado HTML incorrecta116, 020, 185, 186
Enlace de un socket a todas las interfaces de red200
Registro de texto no cifrado de información confidencial312, 359, 532
Almacenamiento de texto no cifrado de información confidencial312, 315, 359
Inyección de código094, 095, 116
Protección CSRF debilitada o deshabilitada352
La versión predeterminada de SSL/TLS puede no ser segura327
Deserialización de datos controlados por el usuario502
La aplicación Flask se ejecuta en modo de depuración215, 489
Falsificación completa de solicitud del servidor918
División de respuestas HTTP113, 079
Expresión regular para nombres de host incompleta020
Saneamiento de subcadena de direcciones URL incompleta20
Expresión regular ineficaz1333, 730, 400
Exposición de la información a través de una excepción209, 497
Archivo temporal no seguro377
Consulta LDPA creada a partir de orígenes controlados por el usuario090
Inyección de NoSQL943
Intervalo de expresiones regulares excesivamente permisivo020
Omisión de autorización de PAM debido a la utilización incorrecta285
Expresión regular polinómica usada en datos no controlados1333, 730, 400
Scripting entre sitios en reflexiones del lado servidor079, 116
Inserción de expresiones regulares730, 400
Consulta SQL creada a partir de orígenes controlados por el usuario089
Línea de comandos no controlada078, 088
Datos usados en la expresión de ruta de acceso no controlados022, 023, 036, 073, 099
Redireccionamiento de direcciones URL desde origen remoto601
Utilización de un algoritmo criptográfico roto o débil327
Utilización de un algoritmo hash criptográfico roto o débil con datos confidenciales327, 328, 916
Utilización de la versión de SSL/TLS no segura327
Utilización de una clave criptográfica débil326
Expansión de entidades externas de XML611, 827
Expansión de entidades internas de XML776, 400
Consulta de XPath creada a partir de orígenes controlados por el usuario643
Escritura arbitraria de archivos durante la extracción de un archivo tar022
Credenciales codificadas de forma rígida259, 321, 798
Plantillas de Jinja2 con autoescape=False079
Inserción de registros117
Permisos de archivo excesivamente permisivos732
Falsificación parcial de solicitud de servidor918
Solicitud sin validación de certificados295
Comando de shell no seguro construido a partir de la entrada a la biblioteca078, 088, 073