Skip to main content

This version of GitHub Enterprise will be discontinued on 2022-02-16. No patch releases will be made, even for critical security issues. For better performance, improved security, and new features, upgrade to the latest version of GitHub Enterprise. For help with the upgrade, contact GitHub Enterprise support.

About GitHub Advanced Security

GitHub makes extra security features available to customers under an Advanced Security license. These features are also enabled for public repositories on GitHub.com.

GitHub Advanced Security is available for enterprise accounts on GitHub Enterprise Cloud and GitHub Enterprise Server 3.0 or higher. GitHub Advanced Security is also included in all public repositories on GitHub.com. For more information, see "About GitHub's products."

About GitHub Advanced Security

GitHub has many features that help you improve and maintain the quality of your code. Some of these are included in all plans, such as dependency graph and Dependabot alerts. Other security features require GitHub Advanced Security.

About Advanced Security features

A GitHub Advanced Security license provides the following additional features:

  • Code scanning - Search for potential security vulnerabilities and coding errors in your code. For more information, see "About code scanning."

  • Secret scanning - Detect secrets, for example keys and tokens, that have been checked into the repository. For more information, see "About secret scanning."

For information about Advanced Security features that are in development, see "GitHub public roadmap." For an overview of all security features, see "GitHub security features."

Deploying GitHub Advanced Security in your enterprise

To learn about what you need to know to plan your GitHub Advanced Security deployment at a high level, see "Overview of GitHub Advanced Security deployment."

To review the rollout phases we recommended in more detail, see "Deploying GitHub Advanced Security in your enterprise."

Enabling Advanced Security features

The site administrator must enable Advanced Security for your GitHub Enterprise Server instance before you can use these features. For more information, see "Configuring Advanced Security features.

Once your system is set up, you can enable and disable these features at the organization or repository level. For more information, see "Managing security and analysis settings for your organization" and "Managing security and analysis settings for your repository."