我们经常发布文档更新,此页面的翻译可能仍在进行中。有关最新信息,请访问英文文档。如果此页面上的翻译有问题,请告诉我们

此版本的 GitHub Enterprise 将停止服务 此版本的 GitHub Enterprise 已停止服务 2020-11-12. 即使针对重大安全问题,也不会发布补丁。 要获得更好的性能、改进的安全性和新功能,请升级到 GitHub Enterprise 的最新版本。 如需升级方面的帮助,请联系 GitHub Enterprise 支持

为 GitHub Enterprise Server 上易受攻击的依赖项启用警报

您可以将 您的 GitHub Enterprise Server 实例 连接到 GitHub Enterprise Cloud,并为实例仓库中易受攻击的依赖项启用安全警报。

GitHub Enterprise Server 的站点管理员(同时也是已连接 GitHub Enterprise Cloud 组织或企业帐户的所有者)可以为 GitHub Enterprise Server 上易受攻击的依赖项启用 安全警报。

本文内容

此文档对您有帮助吗?

帮助我们创建出色的文档!

所有 GitHub 文档都是开源的。看到错误或不清楚的内容了吗?提交拉取请求。

做出贡献

或, 了解如何参与。

关于 GitHub Enterprise Server 上易受攻击的依赖项的警报

We add vulnerabilities to the GitHub Advisory Database from the following sources:

您可以将 您的 GitHub Enterprise Server 实例 连接到 GitHub.com,然后将漏洞数据同步到您的实例,并在包含漏洞依赖项的仓库中生成 安全警报。

将 您的 GitHub Enterprise Server 实例 连接到 GitHub.com 并为易受攻击的依赖项启用 安全警报后,每个小时都会将漏洞数据从 GitHub.com 同步到您的实例一次。 您还可以随时选择手动同步漏洞数据。 代码和关于代码的信息不会从 您的 GitHub Enterprise Server 实例 上传到 GitHub.com。

当 您的 GitHub Enterprise Server 实例 接收到有关漏洞的信息时,它将识别实例中使用受影响版本依赖项的仓库,并向这些仓库中具有管理员访问权限的所有者和人员发送安全警报。 您可以自定义接收安全警报的方式。 更多信息请参阅“关于易受攻击的依赖项的警报”。

为 GitHub Enterprise Server 上易受攻击的依赖项启用安全警报

对 您的 GitHub Enterprise Server 实例 上易受攻击的依赖项启用 安全警报之前,必须将 您的 GitHub Enterprise Server 实例 连接到 GitHub.com。 更多信息请参阅“将 GitHub Enterprise Server 连接到 GitHub Enterprise Cloud”。

  1. 登录到 http(s)://HOSTNAME/login 上的 您的 GitHub Enterprise Server 实例。

  2. 在管理 shell 中,对 您的 GitHub Enterprise Server 实例 上易受攻击的依赖项启用 安全警报。

    $ ghe-dep-graph-enable
  3. 返回到 GitHub Enterprise Server.

  4. 在任何页面的右上角,单击

    用于访问站点管理员设置的火箭图标

  5. In the left sidebar, click Enterprise.

    Enterprise tab in the Site admin settings

  6. 在企业帐户侧边栏中,单击 Settings(设置)

    企业帐户侧边栏中的“设置”选项卡

  7. 在左侧边栏中,单击 GitHub Connect

    企业帐户设置侧边栏中的“GitHub 连接”选项卡

  8. 在“Repositories can be scanned for vulnerabilities”下,使用下拉菜单,然后选择 Enabled

    用于启用扫描仓库有无漏洞的下拉菜单

查看 GitHub Enterprise Server 上易受攻击的依赖项

您可以查看 您的 GitHub Enterprise Server 实例 中的所有漏洞,然后手动同步 GitHub.com 中的漏洞数据,以更新列表。

  1. 在任何页面的右上角,单击
    用于访问站点管理员设置的火箭图标
  2. 在左侧边栏中,单击 Vulnerabilities
    站点管理员边栏中的 Vulnerabilities 选项卡
  3. 要同步漏洞数据,请单击 Sync Vulnerabilities now
    Sync vulnerabilities now 按钮

此文档对您有帮助吗?

帮助我们创建出色的文档!

所有 GitHub 文档都是开源的。看到错误或不清楚的内容了吗?提交拉取请求。

做出贡献

或, 了解如何参与。